Alex realizada en Computadoras e internetSoftware · hace 3 semanas

¿He cambiado de procesador pero no me detecta todos los núcleos ?

Anteriormente, tenía una a4 6300 y ahora tengo una a8 7680. Sucede que al cambiarlo me salió un mensaje no el inicio que decía cpu or memory changed y me daba 2 opciones: una de ir al setup y otra de iniciar. Le di a iniciar y efectivamente no se como explicarlo pero mi pc si reconoce que tengo el a8 7680 pero no sus núcleos, ya que intenté con el msconfig y solo salía un maximo de dos nucleos. Tengo una placa a68hm-e33 v2 de la marca msi. Creo que mi problema es un tema de configuración de bios o algo asi. Ayuda porfas.

2 respuestas

Calificación
  • hace 3 semanas

    Se llama capa de abstraccion de hardwre. Básicamente cuando instalas el SO se adapta al hardware que tienes, sobre todo al procesador y chipset.

    Si cambias la CPU nada mas, el equipo puede arrancar mientras no cambies tambien de chipset (placa base mas actual), pero no te va a "reconocer" el hardware al 100%. Lo mas comun es que no detecte todos los nucleos o hilos. Ahora, si el hardware es muy diferente, te puede dar un pantallazo azul directamente. Por ejempplo, hace años pase de un pentium D a un quad core. Era el mismo socket, pero no me reconocia los 4 nucleos. Mas adelante ya hice un cambio mas grande y pase a un i5 2º generacion (con cambio de placa base) Pantallazo azul directamente.

    Esto se arregla reinstalando el sistema para que se adapta al nuevo hardware. En los windows server hay un comando para desvincular esta capa de abstraccion para cuando hay que migrar el servidor de hardware. Pero creo que los windows "de andar por casa" no soportan esto.

    Por otra parte, se supone queen administrador de dispositivos podrias hacer esto tambien, ahora, nunca lo he probado. La cosa seria ir al administrador de dispositivos, expandir "Equipo" , doble click en lo que habrá (Equipo basado en x64 o algo así) y en la nueva ventanam en controlador, podrias darle a actualizar y el mismo deberia de "autoarreglarse". Cuando te pida reinicio lohaces y ya deberia detectar todo. Esto es teoria, nunca he probado eso.

    Si no funcionara, reinstala windows. Eso no fallará. Por eso cuando hago un cambio de placabase y/o cpu, siempre formateo y hago instalacion limpia.

    Lo que mencionas de la BIOS es referente solo a la bios. Cuando esta detecta una nueva CPU te pide ir a configuracion de la bios al menos una vez por si hay que aplicar algun tipo de configuracion nueva. Conviene ir cuadno te lo aunque no hagas nada para que deje de dar el coñazo a cada arranque. Aunque dependiendo de la bios te lo va a decir a cada arranque hasta que entre o una única vez. Pero lo de los nucleos es cosa de windows.

  • hace 3 semanas

    a mi me paso eso, tube que reinstalar windows y listo. yo lo tengo pirata asi que solo lo instale nuevamente.

¿Aún tienes preguntas? Pregunta ahora y obtén respuestas.